Windows XP Drivers For HP G50-112NR Laptop(Update)

. Wednesday, December 3, 2008

HP G50-112NR
Black Friday sales just ended and some lucky people had a chance to stand in 10 hour lines to Office Depot and buy a brand new HP G50-112NR Laptop for a mere $349 - I Call it a FREE at this price for 15.4" Screen, Intel Dual-Core T3200 Processor, 3Gb of Ram, 160Gb HD, 6 Cell Battery and DVD-RW burner.

Not a big Vista fan? [Me neither]. Not a problem - I'll help you find most of these pesky drivers for XP, which HP is too lazy to provide.

Steps:
After fresh Windows XP install (I'd recommend start with XP CD with SP2 or 3 Built in):

  1. INF Update Utility to properly identify all system components.
  2. Then Video drivers for Intel Graphics Media Accelerator 4500M.
  3. Network Card 
  4. UAA driver for HD Audio and Modem
  5. Conexant HD Audio Modem driver [old one here]  - My helpful readers suggested a different audio driver which worked better for them – Get it here and if bugs you for login/password try this page [ I’ll try to arrange for a different mirror tomorrow]

And at last Wireless Network Wi-Fi driver: Broadcom,Intel and Atheros
You might have ether version, but I'd start with Broadcom first…

Please leave comment which Wi-Fi driver worked for you…

P.S: I received some responses about problems with audio. I’d like to hear your comments how did it worked out for you or not.

Related:
More Drivers Articles

47 comments:

Anonymous said...

Thanks very very much for this help!!! I have it bookmarked on my other computer. You're awesome for leaving this info out for us! God bless!!!!

-Solomon

Peng said...

Thanks a lot1

NoVistaNoThanks said...

What is the process to downgrade this HP machine to XP?

If I install XP from the MIcrosoft CD is the machine functional?

Then I have to figure out which wireless network chipset I have and then find the right driver from your list? How do I load these drivers?

Any help would be greatly appreciated.

Has anybody actually done this and made it work?

Thanks

BoredSysAdmin said...

@NoVistaNoThanks
First Kudos on username :)
I'm sorry if I wrote this article a bit too technical and design toward more experienced crown, but worry not. I'll list articles which help you to go trough the process of downgrade:
http://www.computerworld.com/action/article.do?command=viewArticleBasic&articleId=9040318

http://www.mydigitallife.info/2007/06/22/how-to-downgrade-windows-vista-to-xp/

http://www.informationweek.com/news/windows/microsoft_news/showArticle.jhtml?articleID=205101355


Good luck

BoredSysAdmin said...

Dear Anon, Please provide more info if you'd like advice/assistance.
How do the sound devices appear at device manager, if any?
What service pack of windows XP are you using?
Have you tried to re-install drivers again?

Anonymous said...

Well I have tried to installed all the windows xp 10 times at least. The audio drivers appeared to be installed correctly but no sound card is active in the control panel. Windows XP SP2 original from HP. My SP3 WinXP cd gave me a blue screen when I tried to installed from it.

Anonymous said...

Well this is what I have done:
1. Install WinXP SP2 from HP Cd.
2. Install chipset.
3. Install video.
4. Install smart audio 2.21
5. Install HDMI
I have checked the control panel, audio devices, and there is no sound card activated. It appears in the hardware list.
I do this for a living, it is very frustating. This is a client notebook, I have been fight with this machine since 4 days after the Black Friday.

NoVistaNoThanks said...

Anon - please keep us posted. I'm waiting to try this, but only if you are successful

BoredSysAdmin said...

Hey Anon,
I think you forgot to install kb888111 sp2 patch just before audio drivers install.
Check out for links in my SP3 Audio article on top of guides.
Good Luck

Anonymous said...

Well, I installed WinXP from zero one more time.
1. Chipset SP39903
2. Video Win2k_xp1437
3. kb888111
4. Microsoft UAA Bus driver for HD Audio version 1.00 Rev.B SP33566
5. Conexant High Definition SmartAudio 221 SP39902
6. Faxmodem SP39540
7. HDMI
I am using Windows XP OEM SP2 from HP.
I did all this but I don't have a recognize sound card.
8. kb888111 again, no sound.

Kurt said...

By the way. I have used the normal cd of WinXP SP3 Professional with this machine, but I received a blue error screen. Luckily I have to downgrade a notebook with Windows Vista Ultimate and this machine had the english and spanish cds for winxp sp2 that works with HP laptops. I have also tried to incorporate SP3 to this cd, but again I received the blue error screen.

I am the anonymous of dec 23 8:47, dec 29 9:57, dec 29 10:13, and dec 29 11:19 pm.

Kurt said...

I am crazy with this machine, it is taking me too much time to install windows xp on it. The problem is that my client has a system that does not run on windows vista.

I hope somebody could help me.

BoredSysAdmin said...

Hey Kurt,
I'm sorry you running into all this trouble because of "value oriented" customer :) wink,
but I'd like to help you:
Find "Contact BoredSysAdmin" link on right side of page and send me please screenshots of device manager window and of details tab(s) of any yellow or red marked device(s) if any.
Thx !

SP3 Pro Blues creens on install?? Wierd.... When exactly it happends?

Kurt said...

Hi everybody!

At last I have sound on the HP G50!

Well I will publish what I did later.

HAPPY NEW YEAR TO EVERYONE!!!

NoVistaNoThanks said...

Congrats Kurt!

Is the system completely functional now? Network, video etc.?

Would you please post the entire procedure in as much detail as possible. I still have a new G50-112NR in the box and only have a week left on my return policy if I can't get this downgraded to XP

Thanks

Anonymous said...

Got it.

I had the same audio issues as everyone else, with an HP 118nr.

I installed the MUAA, the k888111 patch, drivers, and everything kept failing.

I found this forum that had a driver that finally worked:

http://h30434.www3.hp.com/psg/board/message?board.id=OS&thread.id=236

The file was "Audio e Modem conexant x Compaq CQ.rar" from http://www.filecloud.com/files/category.php?user_category_id=283210

Good luck! Happy New Years!

BoredSysAdmin said...

Thank you very much Anon, As per your suggestion, I updated the article.

Happy new year to you and all my readers!

NoVistaNoThanks said...

Would one of you technically advanced guys please post the step by step process for downgrading this machine to XP.

I'm running short of time and don't want to spend a week trying to ahck this.

BoredSysAdmin said...

@NoVistaNoThanks

Step 1) Install Windows XP (SP2) from Boot CD

Step 2)Install Device Drivers in order I gave and supplement by this post :
http://h30434.www3.hp.com/psg/board/message?board.id=OS&thread.id=236

Step 3) Enjoy

Step 4) Still not clear? - find a local IT Guru to do it for you

Anonymous said...

Hi,

Can you post cpu-z details for this laptop? I got a sony optiarc 7560s in it. It had a recent firmware update from sony but not from hp. I am not able to flash the firmware since its oem. I observed that I got A-data 2gb ram stick (400 Mhz max) in it and some ramaxel 1gb ram with 333Mhz speed maximum.

BoredSysAdmin said...

Anon, I'm not entirely sure regarding your question, but in any case I do not currently have this laptop available, so sorry - no CPU-Z screenshots.

Anonymous said...

I'm struggling to get the network and sound card going on a G50-126NR. Any help you could offer would be appreciated.

Here's what I have tried.

1) Install fresh SATA slipstreamed XP SP2 on single large partition.
2) Install INF Update utility. (infinst_autol.exe)
3) Install Graphic Drivers (win2k_xp1437.exe)
4) Network Card Driver FAILS... (PCI_Install_5713_0206)



TIA,
Kevin

BoredSysAdmin said...

Hey Anon, Try this sound driver: http://rs354.rapidshare.com/files/138162442/ConexantHDAudio-221_XP.zip

No sure about Network thou, send me (email on front page) screenshot of network device properties (details,device instance id) or post it here

Kevin said...

Thanks for the reply.

All is working on my 126NR except sound. When I run the setup, I get "Driver Installation Failed: Could not find the MEDIA device for this driver."

Conexant HD Audio SmartAudio 221 is installed OK.
HDAUDIO Soft Data Fax Modem with SmartCP is OK.

There is only one Audio Device left to deal with. What is it?

Thanks,
Kevin

BoredSysAdmin said...

Hey Kevin,
Have you installed UAA patch?

http://boredsysadm.blogspot.com/2008/03/windows-xp-sp3-and-microsoft-hd-audio.html

Anand MG said...

Hey man,
I installed Win XP3 in hp laptop dv 2000 series. As usual Audio device is not working.
i have changed the CDSversion to 200 & installed kb8881111 but my "Audio Device on High definition Audio Bus" is still listed in other devices with a yellow question mark sayin on driver for this device has not been installed? wat do?
im searchin for this for almost a week for so many solution but nothing is working...
now im unable to uninstall the device itself. its sayin "it may be needed during boot up so unable to uninstall" ridiculous!!!

JR said...

I'm not sure what I'm doing wrong, but I can't get XP Install to get past the initial driver load. I've tried to add the SATA driver in a streamlined CD, but I guess I don't have have the right file.

Can anyone help me?

BoredSysAdmin said...

Hey JR, do you have G50-112NR laptop or a different model?

JR said...

Sorry for delayed reply.

I finally got it working... frankly I forget how since it was a marathon of trying different SATA drivers streamlined onto the XP install disk but finally it did work after finding the right driver.


Now I'm trying to work through an issue with audio where the audio won't turn on after the notebook comes out of sleep.

JR said...

Anyone else have the same problem with audio not working after coming out of standby?

Been trying several solutions, and nothing seems to work.

DjPinoy said...

I have been trying all day long to put XP onto my G50-112nr. During the process though, I continuously get blue screen w/ the error msg 0x00000007b, (0xf78d2524).

Bought the system on black friday like most other people. Ive waited this long to put XP on the computer trying to tough out Vista but just couldnt do it anymore.

I was wondering if anyone might have some suggestions?

From doing some research on other forums, I have been reading that there is a partition that is locked that is preventing me from downgrading to XP.

Any help would be GREATLY appreciated.

Thank you.

DjPinoy said...

Or, I guess I am technically going thru the same problem that JR was having.

JR, which driver did you find that finally worked on your laptop?

BoredSysAdmin said...

Blue Screen on XP install usually Means you'll need to slipstream SATA drivers into the install. I don't have yet a post about it, but there several across internet. Look up for one uses nLite - its the easiest one.

DjPinoy said...

Okay I will give that a try and then let you know how that goes.

I notice on the nLite site, that, the download available is for XP w/ SP3. Do you know if this will still working for someone w/ SP2?

Thank you again.

DjPinoy said...

So I have attempted to slipstream the sata drivers w/ no luck. I am still getting blue screened. I am about to pull my hair out over this.

Does anyone have any other suggestions or info on trying to downgrade??? Please????

BoredSysAdmin said...

Hey DjP,
Sorry for the troubles you going thru and I wish I had the laptop at hand to verify the info, but I don't. It looks like JR had similar issues (Blue Screens) and it just takes to find the right driver...
Try this post:
http://forums13.itrc.hp.com/service/forums/bizsupport/questionanswer.do?admit=109447627+1240234468298+28353475&threadId=1292979

DjPinoy said...

I've made progress! Thank you in suggesting the other board.

I slipstream SP2 along w/ the 32 bit utility (I slipstreamed the Intel(R) ICH9M SATA ACHI) and finally was able to install XP.

Now, my new problem is trying to find the correct drivers for the wireless card, audio, and touchpad :S

I tried alot of the suggestions for these things (minus the touchpad) on both this board and the other with no luck :S

DjPinoy said...

Another update:

Somehow I was able to get audio installed. I have no idea how I did it, but its there. I am still being prompted to get install another audio driver though for HD audio... I'm still working on that.

Solved the touchpad problems by downloading the drivers for it from the Synaptics website (http://www.synaptics.com/support/drivers). I downloaded the drivers specific for XP.

For the wireless card, I downloaded from Atheros.

In looking in my network connections page, it shows my wireless connection being Atheros and my wired connection as RealTek.... Is this supposed to be like this?

Also in addition to this, the wireless light/button no longer work either. If I press on it, it does nothing and just stays orange the whole time, BUT I have an active, working, wireless connection.

Have no clue if anyone else is experiencing any of this, but technically I guess you could say I have 'successfully' downgraded to XP and have gotten it to 'work'.

Any input or insight to the remaining snags would be greatly appreciated.

Thank you again.

Anonymous said...

tell me location for hp g50 126nr all drivers

Anonymous said...

Rec'ing the msg 'HDAUDIO soft data fax modem with smartCP device preventing machine from entering standby'. Found once I downloaded current ITUNES software, msg stopped.

ashok said...

hi BSA
have successfully degraded my hpg50112nr laptop to xp and installed all the drivers.

But there is a problem with audio driver, when laptop resumes from standby i have no audio and need to install the audio drivers again for the audio to work

could u help me with that
have installed ConexantHDAudio 221_XP driver for audio

Sanjoy said...

I need healp please. i have the original MSDN CD. I'm trying to install the Xp Pro sp2 but having problem. AFter setting up the SCSI hadd driver it's going through the HDD detection then right after the HDD format it's asking fo rthe intel matrix stroage driver again...i don't know what to do ...please help......I also try to create the XP CD with the driver already planted in there then i'm having the EULA error. HELP PLEASE

medasanikamaL said...

Hai

Iam having HPG50-112NR laptop i had degraded my os from vista to windows xp with sp2.My problem is that i cant able get the audio drivers.I had gone through the thread i had tried all the methods which has been suggested in the thread.Please can any one help me in this issue.
Regards
Kamal

kamal said...

Please any one help me in resolving my problem.

Anonymous said...

Amazing Work...
Worked for Me !!!

Sam said...

Does this blog still works?

I am looking for these drivers and the links do not work anymore.

Thank you!

BoredSysAdmin said...

Sam, I have not updated links for a while for 3 year old post, but if you do go to intel support page and choose chipset driver/laptop/ Mobile Intel® 4 Series Express Chipset/window xp pro
You will find all the drives you need